System Outage

Resolved
Operational
Started about 1 year ago Lasted 13 minutes

Affected

App
Updates
  • Resolved
    Update

    We just resolved the issue!

  • Resolved
    Resolved

    We just resolved the issue. Sorry for the inconvenience.

  • Investigating
    Investigating

    We are currently investigating this incident.